
Welcomes you
 

... to 

PiobMasterPro

 In keeping with all Windows© Office style programs, the various options and toolbars can be altered and arranged to suit the way the 
user wants to work. For more information on this, see "Hints on the Office style interface". 

Ceol Mor Software & Publishing Ltd’s home page can be found at www.ceolmor-software.com 
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Introduction
  

 

Thank you for purchasing PiobMasterPro - a new product from Ceol Mor Software Ltd. PiobMasterPro allows you to create or edit a 
musical composition for the Highland Bagpipe. PiobMasterPro is an easy-to-use application, but produces professional results. In 
keeping with all Windows© Office style programs, the various options and toolbars can be altered and arranged to suit the way the user 
wants to work. For more information on this, see "Hints on the Office style interface". 

 

The key features of PiobMasterPro are:-

 

 Powerful user interface to allow positioning of text, music and images anywhere on the page

 Simple user interface to define Musical Structure for composition

 Mutiple document interface

 Multi-part support for tunes with harmonies, up to six parts.

 Real pipe sound playback 

 Samples from the Highland Bagpipe, Practice Chanter or Small Pipes in four seperate keys 

 Printing based on WYSIWYG 

 Drag and Drop facility for Notes, Doublings and Embellishments and Piobaireachd Movements 
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Ceol Mor Software & Publishing Ltd’s home page can be found at www.ceolmor-software.com 

 

Minimum System Requirements

Intel Pentium P4

Windows XP, Vista or Windows 7

16 Mb RAM

10 Mb Disk Space

A 32-bit soundcard 

SVGA or better video system

 

A Note on Intellectual Property

Complex computer programs created with a good deal of hard work by individuals and companies, are valuable intellectual property and 
are protected by trademark, copyright, and patent laws. The details and extent of this protection varies in different countries, but the 
basics are as follows:

Copyright: Computer programs are copyrighted. This happens automatically as soon as the program is written. Further rights may be 
secured by registering the copyright.

Patent: Some applications, if they are distinctive and unusual enough, may be granted a design patent. Only the patent holder or licensees 
may use this design.

http://www.ceolmor-software.com/


piobmasterpro: layout 

 

 

PiobMaterPro has been redesigned with a modern layout look and feel. Important differences from PiobMaster 2.3 are :- 

 The "Ceolmor" button. This custom button contains the functionality to Create, Load, Save and Print PiobMaster documents. 
It also contains "Page Setup functionality and the "Recent Documents" list.

 The "Quick Access" toolbar. This toolbar can be customised to contain the function buttons that the user 
requires. 

 Function "Tabs" and related button "Ribbons". "Insert", "Edit", "Play", "Tools", "Desktop"

 Zoom function that allows the user to determine the zoom factor at anytime. 

officegui.html


 Instrument display which displays the current instrument that has been selected for playback. 

 Style display which offers the user different colour displays for PiobMasterPro. 

 



insert: tab 

PiobMasterPro offers the user the ability to insert pages, text, music and image objects. These objects are the "building blocks " of a 
PiobMasterPro document. They can be inserted and placed in any location on the PiobMasterPro document page. The size of each object 
is determined by the user, were the user actually draws the size of the object on the page. 

 

This tab area is also were the user enters all the required notes, doublings, embellishments and movements required in a tune 

 

They can be accessed from the Area & Notation ribbons under the Insert tab. 

 

 



edit: tab 

PiobMasterPro offers the user the ability to edit all aspects of a PiobMasterPro document. The desired item or object is selected by the 
user, after which the editing functionality within the Edit tab becomes enabled. 

 

The specific editing functionality can be accessed from the Clipboard, Notation, Bars, Text & Actions ribbons under the Edit tab. 

 

 

 



play: tab 

PiobMasterPro Player will playback all or part of a tune if required using the Rewind, Stop, Play or Pause buttons. It can also begin 
playback from the start of a bar as selected by the user. The playback can be placed on a continuous loop if required. 

 

 

The tempo of the playback can also be selected as required. This is especially useful when learning a new tune.

 

PiobMasterPro offers the choise to the user for Highland Bagpipe, Practice Chanter and Small Pipes samples. The small pipes are 
available in the key of Bb, A, C, D.

 

If a tune has multiple parts, such as 2nd's or 3rds', the user can select all parts or just the required part to be played. 

Playback functionality can be accessed from the Control, Tempo & Instrument Selection ribbons under the Play tab. 

 



tools: tab 

PiobMasterPro offers the user the ability to import and export different file formats into and out of PiobMasterPro documents. Supported 
Import formats are PiobMaster 2.3(.pio), Bagpipe Music Writer(.bmw) and Bagpipe Music Writer Gold(.bww) documents. 
PiobMasterPro also includes functionality to export PiobMasterPro to other file formats. Supported formats are Wave file (.wav). Ceol 
Mor Book (.cmb) file format is an in-house export utility only accessable by Ceol Mor Software & Publishing Ltd

 

 

This functionality can be accessed from the Import and Export ribbons under the Tools tab. 

 

 

 



desktop: tab 

PiobMasterPro offers the user the functionality to alter the display and layout of PiobMasterPro document. Page width, page margins, 
status bar and Window selection options are all available 

 

The specific editing functionality can be accessed from the Configuration, View & Window ribbons under the Desktop tab. 

 

To display PiobMasterPro Documents side by side, open 2 or more documents, then click on the document tab and drag it down into the 
editing area.

 





document: open a Piobmasterpro document 

 

 

 To OPEN a PiobMasterPro document, either click the open button in the Quick Access toolbar 

 or click the Ceolmor custom button and select OPEN from the menu. Documents can also be opened from the "Recent Documents" 
List

 



piobmasterpro: document setup overview

 

 

PiobMasterPro offers the user the ability to define the document setup options, such as oreintation, margins and the printer to be used 
for the PiobMasterPro document. ( Paper size can be set within the Printer properties)

PiobMasterPro then offers the user the ability to insert pages, text, music and image objects. These objects are the "building blocks " of 
a PiobMasterPro document. The can inserted and placed in any location on the PiobMasterPro document page. The size of each object 
is determined by the user, were the user actually draws the size of the object on the page. 

They can be accessed from the Area ribbon under the Insert tab. 

 

 

 



document: orientation 

 

 

To select the initial orientation of the new PiobMasterPro document.... 

 

 

 Click on the "Ceolmor" button. 

 Click on "New" menu item. 



 The Page Setup window appears 

 Select either "Portrait"(default) or Landscape" for the page orientation



document: changing orientation 

 

 

PiobMaterPro allows the user to change the orintation of the PiobMasterPro document at anytime. 

  

 Click on the "Ceolmor" button. 

 Click on "Page Setup" menu item. 



 The Page Setup window appears 

 Change either "Portrait"(default) or Landscape" for the page orientation



document: margins 

 

 

To select the initial orientation of the new PiobMasterPro document....

 Click on the "Ceolmor" button. 

 Click on "New" menu item. 



 The Page Setup window appears 

 Set the desired values for the "Left", "Top", "Right" and "Bottom" margins.



document: margins (changing)

 

 

PiobMaterPro allows the user to change the margins of the PiobMasterPro document at anytime. 

 Click on the "Ceolmor" button. 



 Click on "Page Setup" menu item. 



 The Page Setup window appears 

 Set the desired values for the "Left", "Top", "Right" and "Bottom" margins as required

 Margins can be shown/hidden via the Desktop tab

 



document: printer 

 

 

PiobMaterPro allows the user to set the printer that will be used to print the PiobMasterPro document. Choose the desired printer from 
the list of printers currently installed on your PC or Laptop. 

 Click on the "Ceolmor" button. 

 Click on "Print", followed by the "Print Setup" 

menu item. 



 The Print Setup window appears 

 Select the desired printer from the printer dropdown list

 



insert: text 

PiobMasterPro offers the user the ability to insert blocks of text anywhere within a PiobMsterPro document. The text can be accessed 
from the Area ribbon under the Insert tab. 

 

 To INSERT a new text object in the PiobMasterPro document, simply click on the insert text button 

 The cursor changes to a set of cross-hairs. Click, hold then drag the text box to the required size.



 To DELETE a text block, click on the desired text object to be deleted, the perimeter turns blue, then click on the delete button under 

Edit:Actions 

 To MOVE a text block,move the cursor towards the perimeter. The cursor changes to . Then click and drag the text box to the 
desired location on the PiobMasterPro document.



 To RESIZE a text block,move the cursor to any one of the corners of the object. The cursor changes to . Then click and drag the 
text object to the desired size on the PiobMasterPro document.

 



text: properties 

PiobMasterPro offers the user the ability to edit properties of the text blocks that have been positioned within a PiobMsterPro document. 

  SELECT a text block by clicking anywhere within the text block. The perimeter is highlighted in Blue. 

 Either click on the Properties button unter the Edit tab or right-click and select properties from the menu.



 Set the desired text properties, including font type, colour etc.. 
 



text: justification 

PiobMasterPro offers the user the ability to edit the justification of the text within text blocks that have been positioned within a 
PiobMsterPro document. 

 
 SELECT a text block by clicking anywhere within the text block. The perimeter is highlighted in Blue. 



 
 

  

 

 Select one desired justification option for the text.
 



insert: image 

PiobMasterPro offers the user the ability to insert images anywhere within a PiobMsterPro document. The image object tool can be 
accessed from the Area ribbon under the Insert tab. 

 

 To INSERT a new image in the PiobMasterPro document, simply click on the insert image button 

 The cursor changes to a set of cross-hairs. Click, hold then drag the image box to the required size.



 

The image dialog box appears 



Click on the browse button and select the image to be displayed. The image can be in .JPG, .BMP, .GIF, .PNG or .ICO format.

 



 To DELETE an image, click on the desired image to be deleted, the perimeter turns blue, then click on the delete button under 

Edit:Actions 

 To MOVE an image,move the cursor towards the perimeter. The cursor changes to . Then click and drag the image to the desired 
location on the PiobMasterPro document.





 To RESIZE an image, move the cursor to any one of the corners of the image. The cursor changes to . Then click and drag the image 
to the desired size on the PiobMasterPro document.





image: properties 

PiobMasterPro offers the user the ability to edit any image that has been positioned within a PiobMsterPro document. 

 

 SELECT an image by clicking anywhere within the image The perimeter is highlighted in Blue. 





 Either click on the Properties button unter the Edit tab or right-click and select properties from the menu.





 Browse to the new image location to replace the existing image
 

 

 

 



insert: music 

PiobMasterPro offers the user the ability to insert blocks of music anywhere within a PiobMsterPro document. The music object tool can 
be accessed from the Area ribbon under the Insert tab. 

 

 To INSERT a new music object in the PiobMasterPro document, simply click on the insert music button 

 The cursor changes to a set of cross-hairs. Click, hold then drag the music box to the required size.



 



 To DELETE a music object, click on the desired music object to be deleted, the perimeter turns blue, then click on the delete button 

under Edit:Actions 

 To MOVE a music object,move the cursor towards the perimeter. The cursor changes to . Then click and drag the music object 
to the desired location on the PiobMasterPro document.

 To RESIZE a music object,move the cursor to any one of the corners of the object. The cursor changes to . Then click and drag 
the music object to the desired size on the PiobMasterPro document.



 

 

 



properties: insert stave 

 Click on the music object to select it. Use EDIT: PROPERTIES or right-click properties to display the music properties window. 

 To insert an additional stave line into the music object, Click on the INSERT button on the "Insert Staves" section of the music 
properties window. 

t

 To remove a stave line from the music object, click on the REMOVE button. 

 



properties: insert bars to stave line 

 Click on the music object to select it. Use EDIT: PROPERTIES or right-click properties to display the music properties window. 

 To insert additional bars to the stave line in the music object, Click on the bar number of the bars column under the "Insert Staves" 
section of the music properties window. Then use the right arrow button to increase the number of bars in that stave line. 

t

 To remove bars from the stave line in the music object, Click on the bar number of the bars column under the "Insert Staves" section 
of the music properties window. Then use the left arrow button to decrease the number of bars in that stave line. 

 Similarly, a user can insert a bar from the EDIT tab. 

 Click on a particular bar, on the selected stave line where you want the bar to be inserted. Click on the Insert Bar button 



 

 The inserted bar appears to the left of the selected bar 

 

 



properties: insert parts 

 Click on the music object to select it. Use EDIT: PROPERTIES or right-click properties to display the music properties window. 

 To insert an additional part into the music object, Click on the INSERT button on the "Insert Parts " section of the music properties 
window. 

t

 To remove a part from the music object, click on the REMOVE button. 

 



properties: insert time signature 

 Click on the music object to select it. Use EDIT: PROPERTIES or right-click properties to display the music properties window. 

 To insert the time signature of the music object, Click on the Initial Time Signature dropdown menu and select the required time 
signature from the music properties window. 

t

 



properties: set stave spacing 

 Click on the music object to select it. Use EDIT: PROPERTIES or right-click properties to display the music properties window. 

 To set the stave spacing of the music object, Click on the up or down arrows to increase or decrease the spacing between staves 

 



properties: set display options 

 Click on the music object to select it. Use EDIT: PROPERTIES or right-click properties to display the music properties window. 

 To set the display settings for the music object, select the desired options as required. Options available are:- 

 Show/Hide Highland Bagpipe Key Signature on stave 
 Show/Hide the Time Signature on stave 
 Show/Hide Mid-Stave bar Lines 
 Change Stave background colour via colour picker 

 



properties: bar properties 

 To add or remove start bar, end bar lines or change the time signature between bars, click on a bar and use EDIT: PROPERTIES to 
display the Bar Properties window. You can also use the mouse right click menu: properties option 

 



insert: Notes, Doubling, Embellishments & Piobaireachd 
Movements Overview 

 

 

PiobMasterPro offers the user the ability to insert a variety of notes, doublings, embellishments and movements onto a music object 
stave. They can be accessed from the Notation ribbon under the Insert tab.

Doublings, embellishments and piobaireachd movements "Snap" exactly onto the correct position within the stave

 



insert: page 

PiobMasterPro offers the user the ability to insert a new page as part of the PiobMasterPro document. The page layout is determined by 
the options set in the "Page Setup" dialogue.

To insert a new page in the PiobMasterPro document, simply click on the insert page button

   



A new page is added to the PiobMasterPro 
document  

   

To delete a page, click on the desired page to be deleted, then click on the delete button under Edit:Actions 

 

 

 



insert: notes 

PiobMasterPro offers the user the ability to insert a variety of notes onto a music object stave. These notes are semi-brieve, minim, 
crotchet, quaver, semi-quaver, demi-semi-quaver, gracenote. The notes tool can be accessed from the Notation ribbon under the Insert 
tab. 

 

 

 

 To INSERT a new note onto the stave, simply click on the desired note, say the crotchet, and click it onto the desired location on the 
music stave. This process can be repeated as many times as is required, with any of the notes available. 



 The cursor changes to a set of cross-hairs. Click, hold then drag the image box to the required size.
 

 To SELECT a note, either click on the note head or click and drag the cursor around the note. The note colour changes to blue to 
signify that it selected. 

 To SELECT a group of notes, click on any note head within the group or click and drag the cursor around the group of notes.

 To MOVE a single note, select it and drag it to its new position within the stave. You can move notes between music objects.
 

 To MOVE a group of notes, select the note group and drag it to it's new position within the stave. You can move notes between 
music objects. 
 

 To ALTER a note with a group of notes, holding down the ALT key, select the note to be moved and drag it to it's new position 
within the note group. The pitch of the note can be altered within the note group 
 

 To DELETE a note or group of notes, select the desired note or group of notes to be deleted, then click on the delete button under 

Edit:Actions 
 

 

 

 



insert: doublings 

PiobMasterPro offers the user the ability to insert doublings, half doublings and doublings with back gracedoublings within music object 
stave. All doublings are included and "snap" exactly to the correct position within the music stave. The doublings tool can be accessed 
from the Notation ribbon under the Insert tab. 

 



 

 

 To INSERT a new doubling onto the stave, simply click on the desired doubling and click it onto the desired location on the music 
stave. The doubling snaps exactly to the correct position within the stave. This process can be repeated as many times as is required, 
with any of the doublings available. 

 
 

 To SELECT a doubling, either click on note within the doubling or click and drag the cursor around the doubling. The doubling 
colour changes to blue to signify that it selected. 

 

 To MOVE a doubling, select it and drag it to its new position within the stave. You can move doublings between music objects.
 
 

 To DELETE a doubling select the desired doubling to be deleted, then click on the delete button under Edit:Actions 
 

 

 

 



insert: embellishments 

PiobMasterPro offers the user the ability to insert an embellishment within music object stave. All embellishments are included and 
"snap" exactly to the correct position within the music stave. The embellishments tool can be accessed from the Notation ribbon under 
the Insert tab. 

 



 

 

 To INSERT a new embellishment onto the stave, simply click on the desired embellishment and click it onto the desired location on 
the music stave. The embellishment snaps exactly to the correct position within the stave. This process can be repeated as many times 
as is required, with any of the embellishments available. 

 
 

 To SELECT a embellishment, either click on note within the embellishment or click and drag the cursor around the embellishment. 
The embellishment colour changes to blue to signify that it selected. 

 

 To MOVE a embellishment, select it and drag it to its new position within the stave. You can move embellishments between music 
objects.
 
 

 To DELETE a embellishment select the desired embellishment to be deleted, then click on the delete button under Edit:Actions 

 

 



insert: piobaireachd movement 

PiobMasterPro offers the user the ability to insert piobaireachd movements within the music object stave. All piobaireachd movements 
will "snap" exactly to the correct position within the music stave. The piobaireachd tool can be accessed from the Notation ribbon under 
the Insert tab. 



 

 

 To INSERT a new piobaireach movement onto the stave, simply click on the desired piobaireach movement and click it onto the 
desired location on the music stave. The piobaireach movement snaps exactly to the correct position within the stave. This process can 
be repeated as many times as is required, with any of the piobaireach movements available. 

 
 

 To SELECT a piobaireach movement, either click on note within the piobaireach movement or click and drag the cursor around the 
piobaireach movement. The piobaireach movement colour changes to blue to signify that it selected. 

 

 To MOVE a piobaireach movement, select it and drag it to its new position within the stave. You can move piobaireach movements 
between music objects.
 
 

 To DELETE a piobaireach movement select the desired piobaireach movement to be deleted, then click on the delete button under 

Edit:Actions 
 

 



grouping: overview 

 

 

PiobMaster offers the user the facility to group notes together. To do this the user "Rubber Bands" around the group of notes, turning 
their colour blue, and then selects the "Group Notes" button 

 

This action joins each stem of the grouped notes together.

The user can also tie two notes together with the tie symbol. Again the two notes are selected as stated above, but this time the "Tie" 
button is pressed

Also the user can place the "Triplet" symbol over a group of three notes. The procedure is the same, apart from three notes must be 
selected

 



edit: grouping notes 

 

 
To group a number of notes together :- 

 Click and hold down the left mouse button beside the group of notes to be grouped

 Drag the mouse, placing the "Rubber Band" around the group of notes.

 The group of note's colours change to blue

 Press the "Group Notes" button on the main window, or use the keyboard shortcut by pressing on the G key

 The notes are now grouped together

 To group a number of notes again, simply follow the above procedure again

 Note!! The user cannot select notes if the "Rubber Band" is not within the a single bar

 





edit: ungrouping Notes 

 

 

To ungroup a number of notes:

 Click and hold down the left mouse button beside the group of notes to be ungrouped

 Drag the mouse, placing the "Rubber Band" around the group of notes

 The group of note's colours change to blue

 Press the "Ungroup Notes" button on the main window, , or use the keyboard shortcut by pressing on the U key 



The notes are now ungrouped

Note!!

The user cannot select notes if the "Rubber Band" is not within the a single bar

 



edit: Tying Notes 

 

 

To tie two notes together:

 Click and hold down the left mouse button beside the two notes to be tied

 Drag the mouse, placing the "Rubber Band" around the two notes 

 The two notes change their colour to blue 

 Press the in the Edit:Notation area. 

 The two notes are now tied together

 



edit: Tying Notes as Triplets 

 

 

To tie three notes together as triplets:

 Click and hold down the left mouse button beside the three notes to be tied as triplets

 Drag the mouse, placing the "Rubber Band" around the three notes 

 The three notes change their colour to blue 

 Press the "Tie" button in the Edit:Notation area. 

 The three notes are now tied together as triplets 

 



edit: untying Notes 

 

 

To untie two notes:

 Click and hold down the left mouse button beside the two notes to be untied

 Drag the mouse, placing the "Rubber Band" around the two notes

 The two notes change their colour to blue

 Press the "Tie" button or use the keyboard shortcut by pressing on the T key

 The two notes are now untied



 The above procedure is the same for untying triplets

 



edit: "dot" & "cut" overview 

 

PiobMasterPro offers the facility facility to dot or cut notes. To do this the user selects a note, turning its colour blue, and then selects 
the "Dot" button or the "Cut" button This action places a dot or cut on the selected note.

The user can "Undot" or "Uncut" a note by selecting the note and then clicking on the "Dot" button or the "Cut" button again.

 



edit: "dotting" a note 

 

To "Dot" a note :- 

 Positioning the mouse pointer over the note head

 Click on the left mouse button 

 The note colour turns blue signifying that the note has been selected

 Click on the "Dot" button or use the keyboard shortcut by pressing on the D key 

 The note now has a dot placed after it

 

 The note now has a dot placed after it

 



edit: "cutting" a note 

 

 

 Positioning the mouse pointer over the note head

 Click the left mouse button 

 The note colour turns blue signifying that the note has been selected 

 Click on the "Cut" button or use the keyboard shortcut by pressing on the C key 

The note is now cut

 



edit: "undotting" a Note 

 

 
To "undot" a note:

 Positioning the mouse pointer over the note head

 Click the left mouse button 

The note colour turns blue signifying that the note has been selected

 Click on the "dot" button or use the keyboard shortcut by pressing on the D key

 The dot has now been removed from the note

 



edit: "uncutting" a Note 

 

To "uncut" a note:

 Positioning the mouse pointer over the note head

 Click the left mouse button 

The note colour turns blue signifying that the note has been selected

 Click on the "Cut" button , or use the keyboard shortcut by pressing on the C key 

 The cut has now been removed from the note



edit: adding 1st and 2nd Timings 

 

 Click on the bar that the 1st timing is to start from 

 Click on the "Insert Repeats" button 

 1st and 2nd repeats are inserted above the selected bar and its adjacent bar 
 

 



edit: adjusting 1st and 2nd repeat Timings 

 

 Click on the the "1" of the 1st timing repeat marker 

 Click and drag the mouse down onto the stave line. Continue to hold down the mouse button and slide the 1st timing repeat marker 
to its desired position

 Repeat process to adjust the 2nd timing repeat marker 
 

 



edit: deleting 1st and 2nd Timings 

 

 Click on the bar that the 1st timing is above

 Click on the "Delete Repeats" button 

 1st and 2nd repeats are deleted above the selected bar and its adjacent bar 
 

 



edit: annotating 1st and 2nd Timings markers 

 

 Click on the bar that the "1" of the 1st timing. The Change Marker windows appears 

 

 Enter the desired letter or number

 Repeat for the "2" of the 2nd timing 
 

 



edit: copy & paste overview 

 

PiobMasterPro offers the user the facility to copy & paste notes, doublings, embellishments & movements from within bars of a single 
music object, bars of seperate music objects and between music objects on multiple opened documents.

PiobMasterPro also allows complete Text, Music and Image objects to be copy & pasted within the same document and also between 
multiple opened documents 

 



edit: copying & pasting 
 

 Click on any note, doubling, embellishment, movement, text object, music object or image object 

 Click on the Copy Button or press "Ctrl C" 

 

 Click on the desired location were the item is to be Pasted 

 Click on the "Paste" button or press "Ctrl V " 



 The new item has been pasted into its new postion 

 



properties: note groups 

 To alter note group properies, select a group of notes and click on the EDIT: Properties button. The Note, its Type, Dot & Cut can all 
be adjusted 



properties: note weightings 

 PiobMasterPro allows the user to adjust the relative weighting of each note within a group. The relative weighting is adjusted with its 
individual slider. 



properties: change time signature 

 PiobMasterPro allows the user to change the time signature within parts of a musical composition 

 To change the time signature within the music object, Click on a particular bar, on the selected stave line where you want the new 
time signature to begin from. Click on the EDIT: PROPERTIES or right-click properties. Select the new time signature from "Change 
Time Signature" drop down list, or enter a custom time signature from the bar properties window 

 



edit: note value checker 

 

PiobMasterPro offers the user the facility to check that the correct number of notes are entered in a bar for the designated time signature. 
Depending on the time signature and the sum of the note values in a bar, the bar will be highlighted in Red, Green or None when the Note 
Checker button is toggled ON or OFF 

 The colours shown :- 

 Red - Note value sum for bar is too large 
 Orange - Note value sum for bar is too little 
 None - Note value sum for bar is correct 



edit: space evenly overview 

 

PiobMasterPro offers the user the facility to evenly space main notes within the bar. To perform this function, the user selects the music 
object then clicks on "Space Evenly" button found in the EDIT:ACTIONS area 

 Notes randomly inserted in a bar 



 After clicking on the "Space Evenly" button 



edit: layering 

 

PiobMasterPro offers the user the facility to "Layer" Text, Music or Image Objects. To perform this function, the user selects the object 
then clicks on found in the EDIT:ACTIONS area 

Click on the "Bring to Front" or "Send to Back" button to layer an Text, Music or Image object 



play: overview 

PiobMasterPro will play back all or part of a tune if required using the Rewind, Stop, Play or Pause buttons. It can also begin playback 
from the start of a bar as selected by the user. The playback can be placed on a continuous loop if required. 

The tempo of the playback can also be selected as required. This is especially useful when learning a new tune.

PiobMasterPro offers the choice to the user for Highland Bagpipe, Practice Chanter and Small Pipes samples. The small pipes are 
available in the key of Bb, A, C, D.

If a tune has multiple parts, such as 2nd's or 3rds', the user can select all parts or just the required part to be played. 

Playback functionality can be accessed from the Control, Tempo & Instrument Selection ribbons under the Play tab. 

 

 

 

 

 

 

.



play: select notes 

PiobMasterPro will only playback the selected notes if a user so wishes. This is especially useful when learning a new tune. Otherwise, 
if no notes are selected then the complete tune is played back



play: Controls

PiobMasterPro contains a number of controls to allow the user to playback the entire tune or the selected group of notes. Details of 
each of the controls functionality is listed below.

 This control rewinds the tune back to the beginning.

 This control stops the playback.

 This control starts the playback.

 This control pauses the tune. Play will commence from this point

 This control will cause the tune playback to loop.

 



play: Tempo

PiobMasterPro allows the user to adjust the tempo at which the tune is played back. The tempo is scaled to "Beats Per Minute" (BPM).

 PiobMasterPro - Tempo Slider

 Adjust the tempo by sliding the pointer to + (Increases Tempo) or - (Decreases Tempo). The actual tempo value is shown in the 
tempo numeric field. 

 Similarly, the tempo can be specified by directly editing the tempo numeric field

 



play: Instruments

 

PiobMasterPro contains a number of instrument samples which can be used to playback the tune. The playback samples are found in 
the Play:Instruments area. 

PiobMasterPro offers the choise to the user for Highland Bagpipe, Practice Chanter and Small Pipes samples. The small pipes are 
available in the key of Bb, A, C, D.



 This control selects Highland Bagpipe samples to be used for playback.

 This control selects Practice Chanter samples to be used for playback

 This control selects Small Pipes samples to be used for playback.



play: select part 

In PiobMasterPro, if a tune has multiple parts, such as 2nd's or 3rds', the user can select all parts or just the required part to be played. 
This is especially useful when learning in a pipeband environment.

 



document: save a Piobmasterpro document 

 

 

 To SAVE a PiobMasterPro document, either click the save button in the Quick Access toolbar 

 or click the Ceolmor custom button and select SAVE from the menu 



 



document: print a Piobmasterpro document 

 

 

 To PRINT a PiobMasterPro document, either click the Print button in the Quick Access toolbar 

 or click the Ceolmor custom button and select PRINT from the menu 



 



document: Zoom

PiobMasterPro Player allows the user to zoom into and out of a document. The zoom factor can be adjusted to between 50% and 300% 
magnification. To adjust the zoom factor, follow the steps below. 

  PiobMasterPo - Zoom Control
  Load a tune as normal.
  The zoom control is located in the bottom right hand of the document 

viewer window.
  Set the zoom factor by sliding the pointer to the desired value.



edit: Keyboard Shortcuts 

 

 

PiobMasterPro offers the user the facility of using keyboard shortcuts for performing various tasks within PiobMasterPro

The keyboard key and is corresponding task are as listed below:-

 G - for Grouping Notes
 U - for Ungrouping Notes
 D - for Dotting or Undotting Notes
 C - for Cutting or Uncutting Notes
 T - for tying or Untying Notes
 Ctrl C - for Copying Music, Text & Image Objects or Notes, Doublings, Embellishments & Movements 
 Ctrl V - for Pasting Music, Text & Image Objects or Notes, Doublings, Embellishments & Movements 
 Del - for deleting Music, Text & Image Objects or Notes, Doublings, Embellishments & Movements 

 



import: open a Piobmaster 2.3 document 

 To OPEN a PiobMaster2.3 document, click the Import PiobMaster 2.3 button in the Tools:Import area 

 then select the PiobMaster 2.3 .pio tune to be imported from the Open window 



 The PiobMaster 2.3 tune is now successfully loaded into PiobMasterPro 



import: open a Bagpipe music writer document 

 To OPEN a Bagpipe Music Writer document, click the Import Bagpipe Music Writer button in the Tools:Import area 

 then select the bagpipe music writer .bmw or .bww tune to be imported from the Open window 



 The bagpipe music writer tune is now successfully loaded into PiobMasterPro 



export: piobmasterpro document to a .wav file 

 To EXPORT a PiobMasterPro document to a .wav file, click on the button in the Tools:Import area 

 then define the .wav filename in the the Open window 



 PiobMasterPro has now created a .wav file of the PiobMasterPro document 



Hints on Office style user interface
  

 

The Windows© Office style interface that has become popular over recent years, especially with Vista© and Windows-7© users, can be 
a little awkward to get used to if you are new to it. In particular for PiobMasterPro users, things like floating toolbars are no longer 
available, but Quick-Access Toolbars are. This means that to keep your working practices as slick and efficient as before, you need to 
know how to use the new Office style toolbars to maximum effect. This is a short introduction as to how you can go about customising 
the PiobMasterPro program layout, so as to adapt it "on-the-fly" to your way of working.

PiobMasterPro, in line with all Office style programs, will remember your toolbar layout when you close the program. The next time you 
load PiobMasterPro, your working scenario will be just as you left it.

 

General Layout

In an Office style application there is an "application" button in the extreme top left of the screen, which gives access to menu items such 
as for loading and saving files, printing, selecting recently used files and so on. It normally contains an icon which identifies the 
application and in the daigram below for PiobMasterPro this is seen to be the Ceolmor Ltd logo.



 

 

To the right of this icon there is as standard (it can be changed, see later under "Customising the Quick-Access Toolbar"), a series of 
small icons spread left to right, and this is known as the Quick-Access Toolbar. If you put your mouse over the first icon, which looks 
like a small plain sheet of paper, the toolbar tool-tip will tell you it is the button to create a new document. The next one along, which 
looks like a small folder, is for opening a currently existing file. The third one along, which looks like a mini-floppy-disk, is the save 
button, and so on. Now, all of the above is true "as standard". The beauty, and difficulty when it comes to documentation like this, of the 
Quick-Access Toolbar is that it can be customised to suit how the user works. So it doesn't "have" to be as described above.

 

Below the Quick-Access Toolbar there are the application menus, which for PiobMasterPro are things such as "Insert", "Edit", "Play", 
"Tools" and so on. Each menu has a series of Grouped Options in what is called a Ribbon Bar. For example, the "Edit" menu in the 
above diagram has Groups called "Clipboard", "Notation", "Bars" etc. The "Bar" group has options for "Insert bar", "Insert repeats" and 
"Delete repeats". In other words the menu Groups within the overall command Ribbon are the application's way of putting related 
commands together, to make the use of the program easier. 

 

Hard Work?



Users of older style interfaces will often be faced with what seems a more difficult and long-winded way of doing things. For example, 
suppose we use the example of opening a new document, putting down a music stave, adding some notes, deleting some wrong ones, 
playing what we have, inserting some more notes, grouping some notes and finally playing the tune once more. How are we going to do 
that? It would seem that we would have to spend a fair bit of time moving between the Ribbon Groups to achieve what we want. If we 
spend any amount of time moving between the Insert, Edit and Play menus we are soon going to get very frustrated!

 

But what if we box clever and set the interface up so that life is much quicker and simpler, and organised for what we want to do, ie. 
create and edit some music? This is easily achieved.

 

Customising the Quick-Access Toolbar

There are various ways we can customise the Quick-Access Toolbar: 

 

 Place the mouse over an icon on the Quick-Access Toolbar and right-click. As expected a sub-menu will pop-up and you'll see one of 
the options there is to customise the toolbar. Try it. You will be able to add, delete, and re-order available commands. One of the other 
options is to remove the icon you are currently over from the Toolbar altogether. 

 Place the mouse over a Group name, such as Notation in the Edit menu, and right-click. Again a sub-menu pops up and one option 
will be to add [the Group] to the Quick-Access bar. If you do this another small icon gets added to the Quick-Access Toolbar and you 
can go there to get to any Notation command, instead of having to use the main Ribbon menus.

 Place the mouse over a command button/option, such as Insert bar in the Bars group in the Edit menu, and right-click. Again a sub-
menu pops up and one option will be to add [the command/option] to the Quick-Access bar. If you do this another small icon gets added 
to the Quick-Access Toolbar and you can go there to immediately insert a bar, instead of having to use the main Ribbon command.

 The sub-menus you have seen above also contain an option to show the Quick-Access Toolbar below the Ribbon. This can be handy if 
you decide to put a lot of commands or groups into the Quick-Access Toolbar, becuase they will all appear on a line of their own, intead 
of being pushed up against the application title and document name.



 

You're getting the idea, right? Anything you do to customise your layout of commands can be undone, so there is no risk in you playing 
with various options and finding what works best for you.

 

For example, if you put the Insert-Area, individual Notation buttons (Notes, Doublings etc.), and the Play-Control group in the Quick-
Access Toolbar, leaving the Edit menu ribbon permanently displayed, you can fully and completely edit any new or loaded file, including 
adding and changing notes, play whatever parts of it you want, and save the result as a PiobMasterPro file, all without ever having to 
select a different main ribbon: 

 

 

 



How easy is that? You'll notice the Quick-Access bar has also been moved to below the main Ribbon bar, so the icons are clearer and 
closer to the current worksheet. Still, different people work in different ways and it's just a case of trial and error to get the kind of 
interface you want. Remember, it can always be modified. For example if you added the Tools-Import-v2.3 command to the above 
scenario, you can do all the above but start by importing an old v2.3 file. Bear in mind that PiobMasterPro also keeps track of different 
recently used file directories, such as the last import path and the last PiobMasterPro file path. So now you have a working environment 
for importing, tidying up and/or improving v2.3 files, and saving the results, with the absolute minimum of fuss.

 

Two Important Hints

 

 When you are editing some music, clearly the Edit ribbon commands are the ones you will use the most, as well as inserting notes of 
course. When editing music you can right-click at any time and obtain a pop-up sub-menu that contains ALL the Edit ribbon commands 
(except Lock). This might help you decide how you want to organise the rest of your working interface.

 

 Don't under any circumstances try and make the Office style environment have the look and feel of an older Windows© interface - 
they are completely different! The beauty of the Office style environment is that it is so easily customised to help you work the way you 
want to work. Experiment, try things out, customise to your heart's desire, and the benefits you receive will be amazing.
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